
Affymetrix GeneChip® Targeted Genotyping Analysis Software 
Release Notes 

 
 
GTGS Version:  1.6 
AGCC Version: 1.0 
GCOS Version: 1.4 
 
Topics covered 
AGCC Information for GTGS Users 
GCOS Information for GTGS Users 
Data Transfer Tool Information for GTGS Users 
Installer Limitations 
Launch and Communication Limitations 
User Activity Limitations 
Assay Tracking Limitations 
Data Analysis Limitations 
User Interface Limitations 
Miscellaneous Limitations 
 
NOTE: GTGS has only been verified to work on the Targeted Genotyping Pre-Amp and Post-

Amp computers.  A co-installation of Affymetrix GeneChip Command Console (AGCC) 
and GTGS on the same computer is not supported. 

_______________________________ 
AGCC Information for GTGS Users 
• ‘How can I get GTGS to talk to Command Console (AGCC),’ or, ‘Why is GTGS still 

communicating with GCOS after upgrading to GTGS 1.6?’:  By default, the upgrade installer 
retains the settings used by GTGS 1.5.  This includes registering sample tracking information 
with a GCOS workstation, if the software was configured to do this for GTGS 1.5.  GTGS 1.6 
will either communicate with GCOS, or with AGCC, but not both.  If you wish to use GTGS 
with AGCC, do the following: 
• Log into the Post-Amp Lab workstation as a user with administrative privileges (like 

“Administrator” on “this computer”). 
• Launch Windows Explorer and navigate to the directory C:\Program Files\Apache 

Software Foundation\Tomcat 6.0\webapps\geno\config. 
• Open the file GCOS.properties with Notepad. 
• Set enabled = false 
• Save and close this file. 
• The next time you use GTGS 1.6, you will be asked to select the location to save sample 

files (.ARR) at the appropriate time in the sample tracking workflow. 
 
• 'Why is GTGS not finding AGCC CEL files even after I select the correct folder?:'  GTGS 

expects the CEL files to have a name based on the experiment name used in GTGS.  If your 
CEL files don't use these names, they won't be read by GTGS.  The default experiment 
naming convention for GTGS has the format '(a)1234567-12345'.  The default array naming 
convention for AGCC is the full Affymetrix barcode.  If AGCC hasn't indexed the GTGS-
created .ARR files by the time the arrays are first washed or scanned, then AGCC will itself 
create ARR files, and eventually CEL files, based on the full array barcode. 
• To avoid this problem, make sure that you save the GTGS-created .ARR files in a folder 

managed by AGCC (a folder within an AGCC data root folder), and that you give AGCC 
sufficient time to index these new files, before you wash and scan your arrays. 

• To recover from this problem, you’ll need to create a custom experiment list that points to 
the actual CEL file names.  From Array Data, “Export Experiment List,” edit the “Data File 



Ch A-D” columns with the actual CEL file names, and “Import Experiment List”.  You will 
first need to delete existing experiments with the same names in the desired GTGS 
project. 

 
GCOS Information for GTGS Users 
• Multiple TG Post-Amp Workstations should not point to same GCOS Instrument Workstation: 

GTGS is designed to have only one TG system exchange information with a given GCOS 
system.  Do not configure multiple TG systems to communicate with one GCOS system.  It is 
possible that when a sample is registered with GCOS by GTGS, it may overwrite the same 
sample written by another instance of GTGS. 

 
• “Error - CreateExperiment: Failure in SetupExperiment: Failure in GetProbeArrayFromDb:  

Unknown Probe Array <probe array name>” message: If an array type is undefined in GCOS, 
the user can still register a sample without the associated experiment info. Only projects 
containing supported array types can be successfully registered with GCOS, i.e. a GTGS 
Array Definition must be installed having the same name as the Probe Array Type that exists 
in the GCOS database (also called a Library File).  If you are using a new assay panel, you 
may need to install a new Array Definition, and may need to obtain a new Library File from 
Affymetrix. 

 
• Inappropriate "ERROR DAT and CEL files do not exist: <path to .cel file>" message: During 

an "Import Experiment Data" operation, if file permissions aren't properly set on the GCOS 
shared folder that contains the .cel files, GTGS will report this message, when the message 
should actually be "<path> is not accessible.  You might not have permission to use this 
network resource."  To verify that you actually have a file permission problem, open a 
Windows Explorer window and enter in the address bar 
"\\<GCOS_Computer_Name>\GCLims\Data", and see whether you can see the contents of 
the folder.  Talk to your IT support staff if you don't have the proper permissions. 
 

• "Failed to connect to database on [server]" generic GCOS message: This generic message 
on failure to connect appears regardless of why the connection failed.  This message can 
appear if you are not logged into the current Windows session as a domain user, the GCOS 
computer is off or not connected to the same network as your computer, the GCOS 
computer name has been changed after site installation, the database server on the GCOS 
computer has been inadvertently turned off, or you are not running GTGS from a Pre-Amp 
or Post-Amp Lab Workstation.  This may also happen if the GCOS computer is running 
Windows XP Service Pack 2, and the Windows Firewall or DCOM settings aren't properly 
configured.  See Windows XP SP2 and Firewall Technical Note for GCOS with GTGS.pdf 
for more information.  The failure to connect message may also appear if antivirus software 
is active on the GCOS computer.  See Norton AntiVirus Technical Note for GCOS with 
GTGS.pdf for more information. 

 
• GCOS refresh: If GCOS software is open when GTGS registers experiments (with GCOS), 

the user must refresh the GCOS application to view newly registered experiments. 
 
Data Transfer Tool Information for GTGS Users 
• Can't transfer all DAT and CEL data to a different GCOS computer: There is a limitation in 

Data Transfer Tool 1.1.1 and earlier (version 1.1.0 is installed by GCOS 1.4, but a newer 
version is available from www.affymetrix.com).  When you are asked to "Select Data to 
transfer OUT," you have multiple ways of selecting which data to transfer.  If you display your 
data by DAT or by CEL, not all of your data will be transferred.  Specifically, although the 
file(s) created by DTT contain all the data, the associated XML files only include a reference 
to one of the four .dat and .cel files per experiment.  When DTT is used to import the data to 
a new system, the unreferenced files are not imported.  The recommended procedure for 
using DTT to transfer GTGS data is to display your data by Projects, by Samples, or by 
Experiments, when you are asked to "Select Data to transfer OUT." 



 
Installer Limitations 
• “Error: -1618 Another installation is already in progress.  Complete that installation before 

proceeding with this install.”  If you get this message, click OK and Next to get to the end of 
the install process.  Then immediately re-run the installer twice.  On the first re-run, the 
installer will uninstall existing components.  On the second re-run, the installer will install all 
needed components. 

 
• Wrong GCOS computer name listed in the installer:  If GTGS is currently configured to 

communicate with a GCOS computer, the installer may display the wrong GCOS computer 
name.  This will happen if there are multiple GCOS computers listed in the GCOS.properties 
file.  The installer displays the first entry it finds in this file, even if it is commented out with a # 
prefix.  This issue is limited to the displayed name within the installer, and doesn't alter which 
GCOS computer GTGS communicates with. 

 
• “Database Error: -2147467259 Description: Login failed for user’’. The user is not associated 

with a trusted SQL Server connection.”  If you get this message, click OK and Next to get to 
the end of the install process.  Then rename your computer so that it has fewer than 15 
characters.  Finally, run the installer again. 

 
• Antivirus software partially blocks the installer:  On new GTGS 1.6 installs (for which SQL 

2005 Workgroup Edition Service Pack 2 is preinstalled), Norton Antivirus may prevent the 
SQL jobs from being installed.  Among other things, these jobs do routine database 
maintenance and nightly backups.  The solution is to temporarily turn off Norton Antivirus 
before running the installer on new installs.  This is not an issue for upgrade installs, as the 
jobs already exist. 

 
Launch and Communication Limitations 
• Java Web Start Cache: In the event that GTGS does not launch or when upgrading to a 

newer version, the user should clear the Java cache. Perform the following operations: 
o Launch Java Control Panel: Select Windows Start Menu> Control Panel > Java 
o In the General tab, select View in the Temporary Internet Files section. In the Java Cache 

Viewer window, select all applications and click the X icon (remove selected 
applications).  Close the Java Control Panel windows. 

o Finally, click the GeneChip Targeted Genotyping Analysis Software link from the 
GeneChip TG Software home page. A fresh copy of GTGS will be downloaded for use. 

Clearing the cache may also resolve other problems. Performing this operation does not 
affect saved data and does not need to be performed on a regular basis. 
 

• Java Web Start Security Warning Information: Upon selecting GeneChip Targeted 
Genotyping Analysis Software from the GeneChip TG Software home page, the user must 
press the Start button on the Java Web Start Security Dialog in order to install and run the 
code. This prompt will occur the first time each Windows user launches GTGS, and also 
when GTGS is either updated or cleared from the Java cache. For more information about 
the Java Web Start Security Warning please visit http://java.sun.com. 
 

• “NT Authentication Error" on application launch: GTGS will not launch, displaying this 
message.  This message will correctly appear if an unauthorized user is trying to run GTGS. 
However, this error message may also appear if the date on the local computer is different 
than the domain date, and if during installation GTGS was configured so that the users aren't 
asked to select their names during application launch. 

 



User Activity Limitations 
• Multiple users simultaneously editing information may lead to database errors: GTGS doesn't 

continuously synchronize the information in application memory with what's in the database.  
If two or more users are accessing the same information and one user adds/modifies/deletes 
some information, the other users won't be aware of the changes.  This can lead to 
duplicated work at best, and at worst multiple database errors. 

To prevent this from occurring, all users should avoid changing information in the 
same project from multiple computers at the same time.  Users should also close GTGS 
when not in use.  If GTGS is inactive for an extended period, the user should perform a 
"refresh" operation (accessible from the View menu or by pressing F5) before any additional 
changes are made. 

The only way to recover from undesirable deletions of data is restore the entire 
database from a previous backup, which will lose any changes made since the backup. 
Database restore instructions are provided in the GTGS Software User Guide, Data Storage 
and Server Maintenance chapter. 

 
• Refresh Application: If GTGS is displaying outdated information (more or less items than 

should be appearing), select Menu > View > Refresh (or press the F5 key). If refreshing 
(clearing application memory of outdated information) doesn't help, restart GTGS. 

 
• “Failed to get viewer” error: Generated when user #1 is saving a cluster and user #2 tries to 

access the cluster not yet saved. After the cluster has been saved to the database, user #2 
can access the data. To refresh the view perform the following operations.  First select a 
different tab i.e., “Samples” then navigate back to the saved cluster. 
 

• Local Administrator can always run GTGS: The local administrator of the GTGS computer 
hosting the GTGS database and application server is able to use the GTGS.  This is the case 
even if Windows NT authentication is used to limit user access, and the local administrator is 
not explicitly given permission to use the software. 

 
• Password needed for Admin user: If the application is configured so that a user does not 

have to select their name from a list when the application launches, then the application 
assumes the user is the same as the user who logged into Windows ("NT Authentication").  In 
this situation, when a user selects "Set Admin User" from the Tools menu, the user is asked 
to enter the admin password.  If this is the first time that this operation is performed, the user 
can create an admin password.  This feature is not documented elsewhere.  However, if the 
application is configured so that a user selects their name from a list when the application 
launches, any user can select the admin user without needing to enter a password. Note that 
the GTGS admin user is independent of the Windows Administrator. 

 
• How to reset the Admin user password. If the application has asked for an admin password, 

but you've forgotten the password, here is how to reset the password. 
o Log into the Post-Amp Workstation as a user with Administrative privileges. 
o For GTGS 1.5 -> 1.6 upgrade systems: 

• Navigate to Start Menu > Programs > Microsoft SQL Server > Enterprise Manager 
• Expand the tree in the left pane by selecting Microsoft SQL Servers > SQL Server 

Group > (local) (Windows NT) > Databases > Geno > Tables 
• Right-click on the UserTable entry in the right pane, and select Open Table > Return 

all rows... 
• Find the row of the table where UserName is admin.  In this row, double-click the 

encrypted Password entry, and delete it. 
• Click the Exclamation Point icon (Run).  This will refresh the table.  An empty 

Password field verifies that you've reset the password. 



o For new GTGS 1.6 systems: 
• Navigate to Start Menu > Programs > Microsoft SQL Server 2005> SQL Server 

Management Studio 
• Expand the tree in the left pane by selecting [computer name]> Databases > Geno > 

Tables 
• Right-click on the UserTable entry in the right pane, and select Open Table  
• Find the row of the table where UserName is admin.  In this row, double-click the 

encrypted Password entry, and delete it. 
• Click the Exclamation Point icon (Execute SQL).  This will refresh the table.  An 

empty Password field verifies that you've reset the password. 
o Restart GTGS. 
o From the GTGS Tools menu, select Set User. 
o Select the Admin user, and then edit your password. 

 
Assay Tracking Limitations 
• Experiment Names are not unique:  Neither GTGS nor GCOS support duplicate experiment 

names.  During the ‘Hyb on Arrays’ operation, GTGS uses the array barcode to create the 
experiment name.  If the original Affymetrix barcode is scanned, the last twelve digits of the 
barcode become the experiment name.  However, it is possible (although very rare) that two 
different arrays will have the same last twelve digits.  If this happens, you will get an error.  
Work-arounds are to use a different array, to place a different barcode on the same array, or 
to manually create a unique experiment via GCOS and create a GTGS experiment list entry 
with this new experiment name. 

 
• “java.lang.ArrayIndexOutOfBoundsException: 0 Unhandled Exception” appears when 

importing a sample plate.  To resolve, browse to the sample plate file before pressing Import. 
 
Data Analysis Limitations 
• Maximum recommended project size: The larger the data set is, the more time will be 

necessary to genotype the data and display certain information. It is recommended that you 
limit to 5000 the number of experiments within any single project.  If you know that your 
project will involve 5000 or more samples, you should segregate your data into multiple 
projects of similar size. 

 
• Processing appears to hang on Insert Norm Data: When a user performs a "Process" 

operation within the "Import Experiment Data" window, the first experiment processed may 
take additional time, sometimes on the order of several minutes. Subsequent experiments will 
be processed much more quickly. 

 
• “java.lang.ArrayIndexOutOfBoundsException” appears when trying to View Experiment 

Details.  If this happens, close the Experiment Details window, select Menu > View > Refresh 
(F5 key), then repeat the operation. 

 
• “ The field [Description] is limited to [255] characters. Please revise your entry" appears when 

trying to save Genotype Results to the database, after having entered a description with more 
than 255 characters.  Unfortunately, following the suggestion doesn’t allow for a save.  The 
workaround is to cancel the genotyping operation, select Menu > View > Refresh (F5 key) to 
remove the false Genotype Result in the tree, and then repeat the operation (using a shorter 
description the next time). 

 
• Export Genotypes Results operation continues if cancel after a partial save: In the middle of 

an export, if you press the Close button, and click Yes to abort the operation, the file export 
will appear to have been cancelled.  However, the save operation still proceeds in the 
background.  The only way to stop this is to quit the application. 

 



User Interface Limitations 
• Possible long idle time during navigation: An hourglass icon may occasionally appear when 

the user navigates to a different part of GTGS, or when doing an operation.  This will happen 
whenever GTGS is accessing the database or processing local data.  This is a normal 
occurrence, and the more information needed to be retrieved or processed, the longer the 
idle time will be. 

 
• Windows folder appears empty: This is always the case when selecting the Windows folder 

that contains the .CEL files to be read into GTGS.  However, if a user is using the GTGS 
Open/Save windows to navigate to a different folder, an error message should appear if the 
user is browsing to a folder that (s)he doesn't have permission to access (the error message 
would be " <path> is not accessible.  You might not have permission to use this network 
resource.")  However, instead it appears that you can go into the forbidden folder, but the 
folder appears to be empty. 

 
• Custom zoom settings are lost: This occurs whenever the axis display option is changed on a 

chart viewer. 
 

 
Miscellaneous Limitations 
• Inappropriate External Sort on some table columns: The external sort operation is not valid 

for numbers containing decimals and will not properly sort. The feature was not designed for 
sorting decimal formats, but is still enabled on some of the tables containing decimal values. 
The desired sort can always be obtained by sorting on another column such as a primary 
key, integer or alpha-numeric value. 

 
• “java.io.FileNotFoundException” appears when exporting an assay panel.  To resolve, repeat 

this operation without typing a file name in the File Name field.  This dialog only requires a 
directory to be selected. 

 
• "NullPointerException": If this message occurs, select Menu > View > Refresh (F5 key), then 

repeat the operation. If refreshing doesn't help, restart GTGS. 
 


